Go Back   MBClub UK - Bringing together Mercedes Enthusiasts > Technical > Wheels, Tyres, Brakes & Suspension
MBClub supports BEN Official Stickers @mbclubuk


Wheels, Tyres, Brakes & Suspension Discuss all wheel related matters

Reply
 
Thread Tools
Old 05-01-2017, 02:09 AM   #1
New Member
 
Join Date: Jan 2017
Car: S211 E320CDI
Posts: 2
S211 Rear Self Leveling Suspension - STRANGE PROBLEM

Hello guys and Happy New Year, new to the forum, but reading from quite some time.

So the issue is with S211 E320 CDI 2004, with rear self leveling suspension.
As usual the rear dropped down at some point.

1. Checked all the fuses and relay - hopefully everything was fine
2. Was throwing rear level sensor error - changed, but didn't fix the issue
3. Started throwing internal error in the module - changed, but still nothing
4. Now it's not throwing any errors but still the car is not rising
5. Anyway the issue is that for some reason the module is not powering the operating circuit of the relay and also is not powering the valves of the bellows.
6. I've managed to put power on the operating circuit of the relay as well as on the valves and the car raised and holding the air, but still the problem exists.

I ran out of ideas so far so any help is wanted.

I will help as much as i can.

Thank you guys

Regards
gogoshkin is offline   Reply With Quote
Old 05-01-2017, 07:29 AM   #2
Hardcore MB Enthusiast
 
Join Date: Apr 2013
Location: Taunton
Car: W211 E500. V8 loveliness
Posts: 511
If the relay is functioning properly then the only way to diagnose this is to get it onto a Star machine.
This will run through all the functional tests and pinpoint the actual fault.
Any decent MB independent garage near you will have one and be much cheaper than a main dealer.

Tony
Lyserman is offline   Reply With Quote
Sponsored Links
Old 05-01-2017, 10:37 AM   #3
Hardcore MB Enthusiast
 
grober's Avatar
 
Join Date: Jun 2003
Location: Perth, Scotland
Car: W204 C200CDI Estate
Posts: 21,274
Have you checked the level of the voltage supply to the module itself?
grober is online now   Reply With Quote
Old 05-01-2017, 07:55 PM   #4
New Member
Threadstarter
 
Join Date: Jan 2017
Car: S211 E320CDI
Posts: 2
Thank you for the reply Lyserman - Tony.

Grober yes I did, if you mean the power supply that is powering the module yes it's in normal rates, depends on engine on or off, but yes it supplies 12-ish Volts.
The tester can communicate with the module. The module itself is returning the measures from the:
- voltage and distance (mm) from the level sensor
- the supply voltage
- when you open the drivers door the Wake-up process is turning ON (under other circumstances as well)
- when the car is stationery the lock position is ON

But after the system wake up it's not powering the pins of the relay even when the level sensor is showing car too low and also it's not powering the valves of the bellows.

Still digging, so hopefully soon will post here the solution of this strange issue.

I was thinking, do the module needs some sort of adaptation?

Thank you

Regards
gogoshkin is offline   Reply With Quote
Reply

Tags
leveling, problem, rear, s211, strange, suspension


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools



All times are GMT +1. The time now is 06:33 PM.


MB club UK is A Mercedes Enthusiast club run by enthusiasts for enthusiasts, MBClub UK is in no way affiliated with Mercedes-Benz, DaimlerChrysler or any of their respective trademarks. The posted views of our members are in no way the views of MBClub.co.uk or its owners.
Find us on Google+