Go Back   MBClub UK - Bringing together Mercedes Enthusiasts > Technical > Electronics
MBClub supports BEN Official Stickers @mbclubuk


Electronics In-Car-Entertainment (ICE), satellite navigation, lighting and wiring

Reply
 
Thread Tools
Old 23-02-2010, 01:10 PM   #1
New Member
 
Join Date: Feb 2010
Location: Burton on Trent, Staffs
Car: 1997 C180 Classic Auto
Posts: 8
Question HELP please with these flashing green and red lights

Hi guys, am a newbie on here, so apologies if this might be a moot subject, but I am well and trully stuck nonetheless.
I have a '97 C180 Classic, Auto and up till now not a single problem. Recently I lost my last set of keys and had new set made via the main dealers..in the meantime, I had the car towed back home. I had to be rear-lifted as it is auto and was in Park.
Keys arrived, but have the dreaded red/green light scenario on the mirror. Starter turns but engine wont kick in. Fobs are working no probs to unlock,lock, alarm etc....have tried new batteries in fob, charging car battery, synchronising the key, and still nothing. Would love to disable/bypass the immob as the car is old anyhow....is there a way I can do this, or do I have to fork out once again to the dreaded Dealers??
Thanks in advance and sorry for the narrative...just trying to fit in as much info as poss
GILES is offline   Reply With Quote
Old 23-02-2010, 01:11 PM   #2
Hardcore MB Enthusiast
 
d w124's Avatar
 
Join Date: Dec 2008
Location: london
Car: 300TE s124 E320 w124 3.6project & 300TE-24
Posts: 11,323
Immobiliser PS Welcome to the forum

Last edited by d w124; 23-02-2010 at 01:17 PM. Reason: welcome
d w124 is offline   Reply With Quote
Sponsored Links
Old 23-02-2010, 01:17 PM   #3
New Member
Threadstarter
 
Join Date: Feb 2010
Location: Burton on Trent, Staffs
Car: 1997 C180 Classic Auto
Posts: 8
thanks mate...any ideas what i can do to make it start, or is this a dealer-only remedy??
GILES is offline   Reply With Quote
Old 23-02-2010, 01:23 PM   #4
Hardcore MB Enthusiast
 
d w124's Avatar
 
Join Date: Dec 2008
Location: london
Car: 300TE s124 E320 w124 3.6project & 300TE-24
Posts: 11,323
Quote:
Originally Posted by GILES View Post
thanks mate...any ideas what i can do to make it start, or is this a dealer-only remedy??
I`M NOT SURE MATE BUT SOMEONE WILL COME ALONG
d w124 is offline   Reply With Quote
Old 23-02-2010, 01:37 PM   #5
Banned
 
Join Date: Jul 2008
Location: london
Car: c63 c43
Posts: 402
hi some one i know had same problem i think he had to go to the stealer,not 100% sure though
chiefski26 is offline   Reply With Quote
Old 23-02-2010, 01:41 PM   #6
New Member
Threadstarter
 
Join Date: Feb 2010
Location: Burton on Trent, Staffs
Car: 1997 C180 Classic Auto
Posts: 8
Thanks guys...am trying to avoid giving them any more of my hard earned...already donated 168 for a new key!!....not a speck of gold on the thing either!!
GILES is offline   Reply With Quote
Old 23-02-2010, 02:40 PM   #7
Hardcore MB Enthusiast
 
bennesspipers's Avatar
 
Join Date: Jun 2009
Location: boston,lincs
Car: '95 W202 C220 Elegance, & '96 S210 E230 Elegance.
Posts: 1,549
You did have the ignition ON when you were synchronising the key ?
bennesspipers is offline   Reply With Quote
Old 23-02-2010, 03:17 PM   #8
New Member
Threadstarter
 
Join Date: Feb 2010
Location: Burton on Trent, Staffs
Car: 1997 C180 Classic Auto
Posts: 8
Quote:
Originally Posted by bennesspipers View Post
You did have the ignition ON when you were synchronising the key ?
Hi Bennes, thanks mate....I've tried with the egnition on, off and even in the first position, but still nothing. Any help will be extremely appreciated.
GILES is offline   Reply With Quote
Old 23-02-2010, 04:06 PM   #9
Hardcore MB Enthusiast
 
Alps's Avatar
 
Join Date: Nov 2002
Location: London\Essex
Car: C36 AMG 1997 (SOLD), E55 2004 Silver
Posts: 5,831
is this not the diode in the mirror issue?

replacement mirror is the easiest option, plenty cheap on fleabay!
Alps is offline   Reply With Quote
Old 23-02-2010, 04:11 PM   #10
Hardcore MB Enthusiast
 
d w124's Avatar
 
Join Date: Dec 2008
Location: london
Car: 300TE s124 E320 w124 3.6project & 300TE-24
Posts: 11,323
Quote:
Originally Posted by Alps View Post
is this not the diode in the mirror issue?

replacement mirror is the easiest option, plenty cheap on fleabay!
Very Very cheap
d w124 is offline   Reply With Quote
Old 23-02-2010, 04:33 PM   #11
New Member
Threadstarter
 
Join Date: Feb 2010
Location: Burton on Trent, Staffs
Car: 1997 C180 Classic Auto
Posts: 8
Nice one, thanks.....will try that and keep you updated. Might be a bit of a daft question but would both lights work with a duff diode??
GILES is offline   Reply With Quote
Old 24-02-2010, 10:39 AM   #12
New Member
Threadstarter
 
Join Date: Feb 2010
Location: Burton on Trent, Staffs
Car: 1997 C180 Classic Auto
Posts: 8
Quote:
Originally Posted by Alps View Post
is this not the diode in the mirror issue?

replacement mirror is the easiest option, plenty cheap on fleabay!
thanks for the advice guys...quick update. I've replaced the internal mirror, and with all indexes crossed cranked the engine...alas, the same two lights are flashing and car wont start!!
GILES is offline   Reply With Quote
Old 25-02-2010, 03:22 PM   #13
New Member
Threadstarter
 
Join Date: Feb 2010
Location: Burton on Trent, Staffs
Car: 1997 C180 Classic Auto
Posts: 8
Hey all, update!!
Having spent several days on different forums, harassing Google etc, have been to the Stealers..nice bloke called Pete told me my immobiliser is not disengaging for whatever reason. The car is 13 years old now and am not bothered about having the immobiliser, so been looking at ways to bypass or disconnect the system. so far to no avail, but am calling an auto-electrician over to have a look. Fingers crossed, this wont be silly money. I will share the procedure if this does not break any forum rules as it seems a common problem with our aging beauties.....thanks all.
GILES is offline   Reply With Quote
Old 25-02-2010, 03:54 PM   #14
Hardcore MB Enthusiast
 
bennesspipers's Avatar
 
Join Date: Jun 2009
Location: boston,lincs
Car: '95 W202 C220 Elegance, & '96 S210 E230 Elegance.
Posts: 1,549
I'll be interested to hear the outcome, cant see how that would break any rules,carry on !
bennesspipers is offline   Reply With Quote
Old 04-04-2010, 08:22 PM   #15
New Member
 
Join Date: Sep 2009
Posts: 4
Hi Giles - I've got same problem engine cranks but will not fire and red/green flashing lights on mirror. I suspect either CPS or Immobiliser. Did you get yours disabled? If so how?
BigG is offline   Reply With Quote
Reply

Tags
c180, c180 immobiliser, flashing, flashing green red lights, green, lights, red, w202


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools



All times are GMT +1. The time now is 02:25 AM.


MB club UK is A Mercedes Enthusiast club run by enthusiasts for enthusiasts, MBClub UK is in no way affiliated with Mercedes-Benz, DaimlerChrysler or any of their respective trademarks. The posted views of our members are in no way the views of MBClub.co.uk or its owners.
Find us on Google+