Go Back   MBClub UK - Bringing together Mercedes Enthusiasts > Technical > Electronics
MBClub supports BEN Official Stickers @mbclubuk


Electronics In-Car-Entertainment (ICE), satellite navigation, lighting and wiring

Reply
 
Thread Tools
Old 05-01-2017, 10:07 PM   #1
New Member
 
Join Date: Mar 2011
Car: E280 **********e
Posts: 10
W211 Xenon problem

Hi everyone,

I own a 2006 E280 and I'm experiencing an issue with the passenger side xenon headlamp. It started to flicker occasionally about a year ago and has now stopped working completely. I assumed if was the bulb and bought a replacement but it is still dead so its not that. I've also tried replacing the module the bulb mounts into but still no joy...

Has anyone else had this issue? Curiously, the a/c is not working either now, the status LED on the switch jusg flashes but it might well be coincidence..

Any help would be much appreciated!

Thanks in advance,
Andrew
AD01 is offline   Reply With Quote
Old 05-01-2017, 10:19 PM   #2
Hardcore MB Enthusiast
 
AMGeed's Avatar
 
Join Date: Nov 2008
Location: Bournemouth/Poole Dorset
Car: 2004 W211 E55K ///AMG
Posts: 6,715
Have you tried swapping over the bulb from the working light? It does point to possible ballast replacement.
Got an indy who can check this out for you to confirm the problem?

http://www.mbclub.co.uk/forums/elect...t-failure.html
AMGeed is offline   Reply With Quote
Sponsored Links
Old 06-01-2017, 09:17 AM   #3
New Member
Threadstarter
 
Join Date: Mar 2011
Car: E280 **********e
Posts: 10
Hi AM,

Thanks for that, I haven't tried swapping the bulbs, but I could give it a go. But the new bulbs isn't work some guess ia that it will produce the same result.

I had read about the ballast you mention - do you know where I would buy it from? I don't know if a local specialist but there must be one close enough..

Thanks again,
Andrew
AD01 is offline   Reply With Quote
Old 06-01-2017, 05:33 PM   #4
Hardcore MB Enthusiast
 
AMGeed's Avatar
 
Join Date: Nov 2008
Location: Bournemouth/Poole Dorset
Car: 2004 W211 E55K ///AMG
Posts: 6,715
Hella Xenon Ballast Unit - 5DV008290-004 | incarmotorfactors.co.uk

These ballasts are on eBay at varying prices. Just ensure you get the same part number

I'd get it checked first to confirm that is the problem. Where are you located so someone can maybe suggest an MB indy to do the work?
AMGeed is offline   Reply With Quote
Old 06-01-2017, 08:08 PM   #5
New Member
Threadstarter
 
Join Date: Mar 2011
Car: E280 **********e
Posts: 10
Thanks AM, good idea. I'm near Newmarket in Suffolk.
AD01 is offline   Reply With Quote
Old 06-01-2017, 08:29 PM   #6
Hardcore MB Enthusiast
 
AMGeed's Avatar
 
Join Date: Nov 2008
Location: Bournemouth/Poole Dorset
Car: 2004 W211 E55K ///AMG
Posts: 6,715
Quote:
Originally Posted by AD01 View Post
Thanks AM, good idea. I'm near Newmarket in Suffolk.
This is the guy to sort you out. A well recommended and respected MB indy very close by.

Alex Crow Mercedes Benz Specialists 01449 258185
AMGeed is offline   Reply With Quote
Old 09-01-2017, 07:28 AM   #7
New Member
Threadstarter
 
Join Date: Mar 2011
Car: E280 **********e
Posts: 10
Thanks AM. I'll give him a try.
AD01 is offline   Reply With Quote
Reply

Tags
problem, w211, xenon


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools



All times are GMT +1. The time now is 07:56 AM.


MB club UK is A Mercedes Enthusiast club run by enthusiasts for enthusiasts, MBClub UK is in no way affiliated with Mercedes-Benz, DaimlerChrysler or any of their respective trademarks. The posted views of our members are in no way the views of MBClub.co.uk or its owners.
Find us on Google+