Go Back   MBClub UK - Bringing together Mercedes Enthusiasts > Technical > Electronics
MBClub supports BEN Official Stickers @mbclubuk


Electronics In-Car-Entertainment (ICE), satellite navigation, lighting and wiring

Reply
 
Thread Tools
Old 15-03-2012, 08:18 PM   #1
New Member
 
Join Date: Nov 2008
Car: C-180 W204
Posts: 16
w204 indicator problem

hi hope someone could help. I have 2008 c- class. on turning indicator stalk to left nothing happens ( no left signal) right side works fine . after 15 min it will start working again. happened 2-3 time in past 2 weeks. when this happens the wind screen washer doesn't work but wipers work. not sure if the stalk is faulty or something else wrong. Thanks for any suggestions
w204 is offline   Reply With Quote
Old 31-03-2012, 08:01 PM   #2
Member
 
Join Date: Jan 2010
Car: C250 CDI Sport BE
Posts: 33
Quote:
Originally Posted by w204 View Post
hi hope someone could help. I have 2008 c- class. on turning indicator stalk to left nothing happens ( no left signal) right side works fine . after 15 min it will start working again. happened 2-3 time in past 2 weeks. when this happens the wind screen washer doesn't work but wipers work. not sure if the stalk is faulty or something else wrong. Thanks for any suggestions




The control stalk on my car has also started playing up. Indicate right and the left hand lights flash! Also dipped beam has switched itself off a couple of time. First time in over 30 years of car ownership I have ever experienced a fault like this, but then its the first (and last) time I have owned a Mercedes!
Hammy is offline   Reply With Quote
Sponsored Links
Old 31-03-2012, 10:39 PM   #3
Hardcore MB Enthusiast
 
mauno's Avatar
 
Join Date: Dec 2011
Location: Braintree
Car: W203 C200K T model classic/ W168 1.4 avantgarde
Posts: 307
plug it on SDS with that you can test anything on a Merc even gremlin faults like this. sounds very weird like a reversed connector but if no one touched it, then control module is my guess. are you far from Braintree?
mauno is offline   Reply With Quote
Old 14-04-2012, 02:21 PM   #4
Member
 
Join Date: Jan 2010
Car: C250 CDI Sport BE
Posts: 33
Quote:
Originally Posted by Hammy View Post
The control stalk on my car has also started playing up. Indicate right and the left hand lights flash! Also dipped beam has switched itself off a couple of time. First time in over 30 years of car ownership I have ever experienced a fault like this, but then its the first (and last) time I have owned a Mercedes!
Car just been in for a horrendously expensive A service. The dealer was asked to look at the stalk and of course couldnt find anything wrong. It started playing up again the next day. PCP up in September - counting down the days to happier times when I no longer have a MB in my life!
Hammy is offline   Reply With Quote
Old 04-01-2017, 08:07 PM   #5
New Member
 
Join Date: Oct 2016
Car: C200 estate
Posts: 1
Have 2009 c class coupe wing mirror indicator unit broken need replacement w204
John23 is offline   Reply With Quote
Old 04-01-2017, 09:08 PM   #6
Hardcore MB Enthusiast
 
Join Date: Oct 2011
Location: Birmingham
Car: 2x c43 Amg clio 172 turbo 314bhp
Posts: 1,561
Quote:
Originally Posted by John23 View Post
Have 2009 c class coupe wing mirror indicator unit broken need replacement w204
Unlucky.
Auto-mobile is offline   Reply With Quote
Reply

Tags
indicator, problem, w204


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools



All times are GMT +1. The time now is 06:19 PM.


MB club UK is A Mercedes Enthusiast club run by enthusiasts for enthusiasts, MBClub UK is in no way affiliated with Mercedes-Benz, DaimlerChrysler or any of their respective trademarks. The posted views of our members are in no way the views of MBClub.co.uk or its owners.
Find us on Google+